Translate
Sub Menu
Links Menu
Online Users

In total there are 55 users online :: 1 registered, 0 hidden and 54 guests

Most users ever online was 372 on Thu May 09, 2019 3:50 am

Registered users: Google [Bot] based on users active over the past 60 minutes

Last Online
In order to view the online list you have to be registered and logged in.



We are a free and open
community, all are welcome.

Click here to Register

Theme Porting and Mod-Updates

Request themes in here

Moderator: Integra Moderator

Theme Porting and Mod-Updates

PostAuthor: nGAGE » Thu Apr 12, 2007 7:52 pm

Hi,...

Been Trying to use/port to 141 a little myself... but still always run into stupied small problems :S
Any tips on what to know when porting from phpBB2 or 1.40 to 1.41?

PS: Have replaced the eXtreme Styles Mod from 1.41 (which is v2.3.1) with the latest version through the update check... except the "template.php" there shouldn't be any other files effected by it that are not part of the mod... but anyhow... so far... i didn't notice any problems. Not sure if the "template.php" contains IntegraMod modifications.

I'm also interested to know if you guys have been looking at the latest versions of "Categories Hierarchy v 2.1.x"-packages. These are pretty cool! (would probably be a lot of work though to get those integrated/updated).

Also just wanted to quickly ask why Solaris or Ti2000 are in the Demo, but not in the download-section? Isn't it finished for 1.41 when it's in the demo?

Anyways... I'd like to see themes like iCGstation or zoneCarbon/zoneCopper and BBTech :)
Last edited by nGAGE on Wed Dec 31, 1969 5:00 pm, edited 1 time in total.
[url=http][img=left]http://www.net-clan-gaming.eu/ftp/ngage/images/nEt_v3_sig.png[/img][/url]
User avatar
nGAGE
Sr Integra Member
Sr Integra Member
 
Posts: 248
Joined: Mon Mar 27, 2006 7:28 am

Re: Theme Porting and Mod-Updates

PostAuthor: Helter » Thu Apr 12, 2007 8:10 pm

I think Solaris is done and it was my oversite that it is not currently available. Ill check the files and upload it by the end of the weekend if it is done. I was actually porting Ti2000 on the demo site and got distracted with the IMportal 1.3.0 beta. I think Frost said he was working on iCGstation, but it is a very technical .css template, so it may take a bit of work. BBTech has to be completely redone to eliminate the errors that have plagued it since I first ported it as I really didnt know what I was doing. As for the others, they are on my large list of things to do, but they are getting closer to the top of it <img>
Last edited by Helter on Wed Dec 31, 1969 5:00 pm, edited 1 time in total.
Image
Please do not PM for support
User avatar
Helter
Administrator
Administrator
 
Posts: 4125
Joined: Sat Mar 11, 2006 4:46 pm
Location: Seattle Wa

PostAuthor: nGAGE » Thu Apr 12, 2007 8:36 pm

Nice to hear all this :P
At the moment, I'm just trying to get a thorough understanding of the Themes and porting them, so that creation of theme's doesn't cause too many problems in the future (and the implementation of add-ons for that).

Keep up the great work you guys have done so far <img>


_nGAGEà¢Ãƒ ¢Ã¢â€š ¬Ã… ¾Ãƒâ€šÃ‚ ¢
Last edited by nGAGE on Wed Dec 31, 1969 5:00 pm, edited 1 time in total.
[url=http][img=left]http://www.net-clan-gaming.eu/ftp/ngage/images/nEt_v3_sig.png[/img][/url]
User avatar
nGAGE
Sr Integra Member
Sr Integra Member
 
Posts: 248
Joined: Mon Mar 27, 2006 7:28 am

Re: Theme Porting and Mod-Updates

PostAuthor: Frost » Thu Apr 12, 2007 9:24 pm

Been Trying to use/port to 141 a little myself... but still always run into stupied small problems :S
Any tips on what to know when porting from phpBB2 or 1.40 to 1.41?


There is a difference between porting and updating themes.

Updating themes is what you would do when going from IM 140 to IM 141, because they have already been ported to 140 or made for it, and you're just updating the files.

Porting themes take a lot more work because you have to basically build a new theme that looks like the old one using parts of it, or by adding new files/code etc.

So I would suggest first trying to update a theme (if you must try it yourself)
You could take a 140 theme and install it on a test im141 site and compare the files to the Integra2 theme. On most cases you can overwrite a lot of the files with ones from Integra2 but not all of them.

Some include: overall_header, overall_footer, the cfg, css, index_body (sometimes this doesnt matter, all depends on the theme, if it has different new images instead of just css changes etc.

Then you would look at the differences between the overall_headers, overall_footers etc to see new code added like ctracker, security, etc

If you would like you can just request themes here and one of the team will get it done for you.

Also, you should check out Found It's themes at [url=http]Found It Forums[/url]

He has a massive collection of themes :oops: It apparently took me too long to post this as 2 other people posted before I was done, but yea... what Helter said <img>

Yes I am working on CGIstation right now, and like he said.. it's advanced..
Last edited by Frost on Wed Dec 31, 1969 5:00 pm, edited 1 time in total.
[size=99px]PhpBB3 Themes[/url] ]PhpBB3 Development Center[/url] [/size]

Frost
Sr Integra Member
Sr Integra Member
 
Posts: 776
Joined: Wed Sep 13, 2006 2:04 am
Location: Photoshop CS3

Re: Theme Porting and Mod-Updates

PostAuthor: nGAGE » Fri Apr 13, 2007 6:47 am

The author of that mod has done a no-no and changed so much of the original phpbb code that if integramod were to implement any of the updates past what version we use now, almost all of the current mods would be rendered useless. I have personally tried to update the mod with an installation of im141 and tried to start with a vanilla phpbb, then added most recent CH mod, then started adding all of integramod's mods... I will tell you this... "not going to happen"

He-he... yeah... I didn't even bother trying that... I would have first have to get all the mods, and apply them myself?! ... Pfff... I already have problems adding a Mod when another mod has changed code that contained code to be replaced by a different mod.
So... I wouldn't even bother attempting that! And from the changes I've seen from the new version... It's going toward phpBB3 style... I was kinda sure you guys wouldn't do that (but hoping is ok ;)

There is a difference between porting and updating themes.

Updating themes is what you would do when going from IM 140 to IM 141, because they have already been ported to 140 or made for it, and you're just updating the files.

Porting themes take a lot more work because you have to basically build a new theme that looks like the old one using parts of it, or by adding new files/code etc.


Yeah... of course... I know that! Don't get me wrong... I can be a little confusing at times... I'm currently (aside from my own design/graphics) putting quite a bit stuff from a variety of themes into my new site. From the older phpBB themes, it's often mostly graphics and rarely any big code changes... as most works find with a little editing of the .css and overwriting of the .tpl files. Sometimes (for a certain desired effect, this doesn't work and I need to revert to either existing themes or 1.40 themes and I actually tend to overwrite the tpls often, eventually finding the theme to go wrong somewhere. Mostly a missing </td> or </tr> or </table> somewhere in the tpls that gives me headaches... especially when the older themes are missing something and that (on top of the changes I've made already has to be compensated to close properly at the end :P
Perhaps I should buy one of them "PHP for dummie's" and/or "HTML and CSS for dummie's" books, huh? ;)


If I got any BIG questions... I'll let you guys know... in an appropriate forum though.


_nGAGEà¢Ãƒ ¢Ã¢â€š ¬Ã… ¾Ãƒâ€šÃ‚ ¢
Last edited by nGAGE on Wed Dec 31, 1969 5:00 pm, edited 1 time in total.
[url=http][img=left]http://www.net-clan-gaming.eu/ftp/ngage/images/nEt_v3_sig.png[/img][/url]
User avatar
nGAGE
Sr Integra Member
Sr Integra Member
 
Posts: 248
Joined: Mon Mar 27, 2006 7:28 am

PostAuthor: nGAGE » Fri Apr 13, 2007 10:04 am

OMG... I just can't believe it... wanna know what caused the bug? (I mean... the forum overwriting the fixed width when viewing a post and nowhere else)

in viewtopic_body.tpl... right at the start (the .script-section):
Code: Select all
   <script></script>    


The 1.40 version of iCGstation didn't have this line.
I'm don't really know much about java, but when I had a look at the file, this is what solved it for me... pls let me know if that's incorrect! Thnx!

[code]    function no_thread_stretch(size){//document.write('<link>');      var width;    if (window.innerWidth) //if browser supports window.innerWidth    {       width = window.innerWidth;    }    else if (document.documentElement && document.documentElement.clientHeight) // Explorer 6 Strict Mode    {       width = document.documentElement.clientWidth + 20;    }    else if (document.all) //else if browser supports document.all (IE 4+)    {       width = document.body.clientWidth + 20;    }      document.write('<style>');    document.write('<!--');    document.write('.postoverflow');    document.write('{');    document.write('   width]


2 Solutions work for me...


1) ... adding the ' in front and behind (width - size) in line 23

[code]      document.write('   width]

2) ... adding a : between ".post" and "overflow" on line 21

[code]        document.write('.post]

Now I'm not sure which would be correct, or if eitherone is a fix... Like I said... I don't know about this java stuff... it's just some suspected "inconsistency" (on the line 23) eventhough it did make sense the way it was originally (and trying seemed to solve my problem, but still kept me thinking about it as it didn't make sense to change it) and something that didn't make sense one the ".postoverflow" being one word and not existing in any theme I've seen lately.
Well... it could actually very-well be that because of eitherone of my changes, the java-.script simply didn't function anymore and it solved it as though I had removed the actual line to the java-.script in the tpl file... anyhow...

My guess is that the ".postoverflow" is the typo.

Pls let me know if I should put it back to original and simply remove the line for my theme! Thnx <img>
Last edited by nGAGE on Fri Apr 13, 2007 3:42 pm, edited 1 time in total.
[url=http][img=left]http://www.net-clan-gaming.eu/ftp/ngage/images/nEt_v3_sig.png[/img][/url]
User avatar
nGAGE
Sr Integra Member
Sr Integra Member
 
Posts: 248
Joined: Mon Mar 27, 2006 7:28 am

Re: Theme Porting and Mod-Updates

PostAuthor: Helter » Fri Apr 13, 2007 1:11 pm

there are many inconsistencies in alot of 140 themes. This is because they were ported from many different svn versions of 140 and by many ppl. This is the reason that I have not updated any of them. All the 141 templates I have done so far have been ported directly from Integra2. It is the only way I can know for sure that all templates ive done are correct
Last edited by Helter on Wed Dec 31, 1969 5:00 pm, edited 1 time in total.
Image
Please do not PM for support
User avatar
Helter
Administrator
Administrator
 
Posts: 4125
Joined: Sat Mar 11, 2006 4:46 pm
Location: Seattle Wa

Re: Theme Porting and Mod-Updates

PostAuthor: Frost » Fri Apr 13, 2007 9:25 pm

See, I'm no where near as good as Helter is, so I just "update" the existing mods.

He is right though, I've seen some .. weird stuff in themes I've worked on, and starting from Integra2 and "porting" the theme again yourself to integra2's code is much safer.

I have cgistation on my local server with xampp and it looks perfect, now to upload it to live and check there, then it comes here
Last edited by Frost on Wed Dec 31, 1969 5:00 pm, edited 1 time in total.
[size=99px]PhpBB3 Themes[/url] ]PhpBB3 Development Center[/url] [/size]

Frost
Sr Integra Member
Sr Integra Member
 
Posts: 776
Joined: Wed Sep 13, 2006 2:04 am
Location: Photoshop CS3

PostAuthor: nGAGE » Sat Apr 14, 2007 8:29 am

Just to make sure there isn't any misunderstanding.... The fault that I just reported (I think it was a fault), isn't with any of the templates. It's for those templates that call the "templates/no_thread_stretch.js file in their "viewtopic_body.tpl"

with the line:
Code: Select all
 <script></script>  


The only reason why I used the "iCGstation/viewtopic_body.tpl" for comparising, was the templates fixed centersize layout, which I have on my design... and it was having issues overriding the set centered size to full-width size.
That's how I got to check the "templates/no_thread_stretch.js" as this file will affect all templates that use this java-.script. If all templates are upgraded from the "Integra2"-template, you will run into the same issues I had if you don't remove that line, or double check the java-.scripts code!

Like I said... I don't know if I corrected it with my code change, but it now works for me. Here once more the "no_thread_stretch.js"-code I'm using now]    function no_thread_stretch(size){//document.write('<link>');      var width;    if (window.innerWidth) //if browser supports window.innerWidth    {       width = window.innerWidth;    }    else if (document.documentElement && document.documentElement.clientHeight) // Explorer 6 Strict Mode    {       width = document.documentElement.clientWidth + 20;    }    else if (document.all) //else if browser supports document.all (IE 4+)    {       width = document.body.clientWidth + 20;    }      document.write('<style>');    document.write('<!--');    document.write('.post:overflow');    document.write('{');    document.write('   width: ' + (width - size) + 'px;');    if (document.all)       document.write('   padding-bottom: 20px;');    document.write('   overflow: auto;');    document.write('}');    document.write('-->');    document.write('</style>');}  [/code]

Will be able to finished my design shortly and will let you have a look at it, before I start adding the planned Modifications to my site <img>


PS: I also run my Test-Server on (latest) XAmpp... and I'm now also installing a Debian machine to test with.
Last edited by nGAGE on Wed Dec 31, 1969 5:00 pm, edited 1 time in total.
[url=http][img=left]http://www.net-clan-gaming.eu/ftp/ngage/images/nEt_v3_sig.png[/img][/url]
User avatar
nGAGE
Sr Integra Member
Sr Integra Member
 
Posts: 248
Joined: Mon Mar 27, 2006 7:28 am


Return to IntegraMOD Theme Request

Who is online

Registered users: Google [Bot]

cron